Check our WordPress 101 & 201 FREE Video Tutorials here
Jump to content
alex.panagis

[Rank Math SEO Plugin] Conflict with Default WordPress Author URLs

Recommended Posts

I noticed that there appears to be some sort of conflict between Rank Math and the default WordPress author pages. Is there a way to disable this? I initially thought that it was a theme issue but after reaching out to theme support they pointed out that the issue did not occur when Rank Math was deactivated. 

Hope to hear from you soon!

Share this post


Link to post
Share on other sites

It's fine now, don't worry - this has wasted so much time already so I just decided to redirect the URL to the homepage using Rank Math. 

Edited by alex.panagis

Share this post


Link to post
Share on other sites

Hello Alex,

We are so sorry about that.

Could you please let us know how to replicate this issue so we can check from our end?

We look forward to hearing back from you. 


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites
2 minutes ago, ToddMTS said:

Hello Alex,

We are so sorry about that.

Could you please let us know how to replicate this issue so we can check from our end?

We look forward to hearing back from you. 

Sure, please visit this post here: https://themainframe.ch/anchor-sponsorships/

And then click on the author URL in the box on the top right. It takes you to an error page.

Edited by alex.panagis

Share this post


Link to post
Share on other sites
1 minute ago, ToddMTS said:

Hi Alex,

It is working fine on my test install. You haven't by any chance disabled the author archives?

jHv0x8+

Please let us know.

I checked that author archives were enabled before posting on the forums. It works on other websites for me too, but this theme seems to hook into the default WordPress author page paths and does not adjust to Rank math's modifications to that. Did it work when you visited https://themainframe.ch?

Share this post


Link to post
Share on other sites

Hi Alex,

That's weird. 

Yes, I saw the 404 on your website as well.

We will have to check that theme closely. Could you please let us know which theme that is and if it is a free/paid theme?


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hi,

Thanks a lot. 

We will take a closer look and see what the best way to fix this compatibility issue would be. 

Would really appreciate your patience in this matter. 


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites
On 2/16/2019 at 10:52 AM, ToddMTS said:

Hi,

Thanks a lot. 

We will take a closer look and see what the best way to fix this compatibility issue would be. 

Would really appreciate your patience in this matter. 

Alright, thanks for looking into this - so glad to hear it! :) 

Hope to hear from you soon...

 

Share this post


Link to post
Share on other sites

Hello,

Please share your WordPress login details in the "Sensitive Data" section by clicking the Add button on the top and bottom right-hand side on this ticket and follow the instructions shown in the screenshot below:
rQoczm+

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello,

I couldn't reproduce this issue on my setup with Expertly theme. Please see this screencast: https://i.mythemeshop.com/fIrw2L

Maybe some other plugin active on your site is causing this problem. Can you share your login details in the Sensitive Data Section so we can further debug this issue on your site?

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello,

Only Dashboard & Profile menus are visible when I log in with the provided access details. Can you please give us admin access to your site?

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites
2 minutes ago, Pratik.d said:

Hello,

Only Dashboard & Profile menus are visible when I log in with the provided access details. Can you please give us admin access to your site?

 Looking forward to helping you. Thank you.

Sorry, my mistake, please feel free to try again. 

Share this post


Link to post
Share on other sites

Hello,

I want to perform a Healthcheck on your site using Health Check plugin but whenever I enable Troubleshooting mode in Health Check, the admin menus disappears again and shows only 2 menus Dashboard & Profile. Can you please check that it looks like we still don't have enough access to change your site settings in troubleshoot mode. If you are not comfortable in sharing access then please troubleshoot your site using Health check plugin by following below instructions and also please update your theme to the latest version i.e 1.6.4:

You can follow these instructions on your live website as well, as running this conflict check does not affect your website visitors.

Here are the steps for you to follow.

  1. Log into your WordPress Administrator, and navigate to the dashboard
  2. Navigate to 'Plugins', and go to 'add new'
    T9Ch6
  3. On the next page, enter 'Health Check' in the search bar and wait for the screen to refresh
    d0qdd
  4. The official Health Check plugin by WordPress.org should be visible as the first result. Please install and activate the plugin
    OP6bX
  5. You will reach the plugin page automatically, and a notice will appear. Click 'I understand' to continue
    kmNot
  6. On the WordPress Menu on the left, hover over the dashboard. You will notice a new 'Health Check' option, click on it
    j3RNi
  7. On the page that appears, there will be several tabs. Please navigate to the 'Troubleshooting' tab
    To02q
  8. Press the 'Enable Troubleshooting Mode' to start the troubleshooter
    zDFyO

Once you complete these steps, you are in troubleshooting mode. All the plugins on your website have been disabled only for you. Your theme has also been disabled, but only for you.

To diagnose the root-cause of your problem, you would enable each plugin one by one until an issue is found. The last plugin that causes the issue will probably the cause of the conflict. Here are the steps in more detail.

  1. With all plugins and the theme disabled, try reproducing the issue.
    1. If you still have the issue, your WordPress setup is the root of the problem.
    2. If not, then continue.
  2. On the top bar, navigate to the 'Troubleshooting Mode', hover over it, and enable the MyThemeShop plugin in question. After that, try to reproduce the issue. u7oyK
    1. If you have the issue, the plugin is conflicting with WordPress
    2. If not, then the plugin is not causing issues with WordPress. Continue to the next step
  3. Navigate to the "Troubleshooting Mode" in the top bar again, and enable any other plugin. Then try reproducing the issue. qHIDj
    1. If you have the issue, then the plugin you just activated is conflicting with the MyThemeShop Plugin
    2. If not, then this plugin is not causing issues with the MyThemeShop plugin

Repeat step no 3 by enabling one plugin at a time and checking if the problem exists. When the problem happens, the plugin you last activated is causing the issue.

 

If the issue is still not resolved, then it might be an issue with the theme you are using. Here is how you confirm if your theme and the MyThemeShop plugin are conflicting with each other.

  1. Enter troubleshooting mode again using the instructions above.
  2. Using the Troubleshooting mode, activate your regular theme by selecting the 'Use your current theme option'. kY14f
  3. Activate the MTS plugin you want to check and try to reproduce the issue. u7oyK
    1. If the issue appears, your theme conflicts with the MTS plugin.
    2. If not, then the issue is with another plugin. You can continue enabling other plugins to pinpoint the plugin and contact their support for a resolution.

Once you complete the above steps, please let us know.

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites
1 minute ago, Pratik.d said:

Hello,

I want to perform a Healthcheck on your site using Health Check plugin but whenever I enable Troubleshooting mode in Health Check, the admin menus disappears again and shows only 2 menus Dashboard & Profile. Can you please check that it looks like we still don't have enough access to change your site settings in troubleshoot mode. If you are not comfortable in sharing access then please troubleshoot your site using Health check plugin by following below instructions and also please update your theme to the latest version i.e 1.6.4:

You can follow these instructions on your live website as well, as running this conflict check does not affect your website visitors.

Here are the steps for you to follow.

  1. Log into your WordPress Administrator, and navigate to the dashboard
  2. Navigate to 'Plugins', and go to 'add new'
    T9Ch6
  3. On the next page, enter 'Health Check' in the search bar and wait for the screen to refresh
    d0qdd
  4. The official Health Check plugin by WordPress.org should be visible as the first result. Please install and activate the plugin
    OP6bX
  5. You will reach the plugin page automatically, and a notice will appear. Click 'I understand' to continue
    kmNot
  6. On the WordPress Menu on the left, hover over the dashboard. You will notice a new 'Health Check' option, click on it
    j3RNi
  7. On the page that appears, there will be several tabs. Please navigate to the 'Troubleshooting' tab
    To02q
  8. Press the 'Enable Troubleshooting Mode' to start the troubleshooter
    zDFyO

Once you complete these steps, you are in troubleshooting mode. All the plugins on your website have been disabled only for you. Your theme has also been disabled, but only for you.

To diagnose the root-cause of your problem, you would enable each plugin one by one until an issue is found. The last plugin that causes the issue will probably the cause of the conflict. Here are the steps in more detail.

  1. With all plugins and the theme disabled, try reproducing the issue.
    1. If you still have the issue, your WordPress setup is the root of the problem.
    2. If not, then continue.
  2. On the top bar, navigate to the 'Troubleshooting Mode', hover over it, and enable the MyThemeShop plugin in question. After that, try to reproduce the issue. u7oyK
    1. If you have the issue, the plugin is conflicting with WordPress
    2. If not, then the plugin is not causing issues with WordPress. Continue to the next step
  3. Navigate to the "Troubleshooting Mode" in the top bar again, and enable any other plugin. Then try reproducing the issue. qHIDj
    1. If you have the issue, then the plugin you just activated is conflicting with the MyThemeShop Plugin
    2. If not, then this plugin is not causing issues with the MyThemeShop plugin

Repeat step no 3 by enabling one plugin at a time and checking if the problem exists. When the problem happens, the plugin you last activated is causing the issue.

 

If the issue is still not resolved, then it might be an issue with the theme you are using. Here is how you confirm if your theme and the MyThemeShop plugin are conflicting with each other.

  1. Enter troubleshooting mode again using the instructions above.
  2. Using the Troubleshooting mode, activate your regular theme by selecting the 'Use your current theme option'. kY14f
  3. Activate the MTS plugin you want to check and try to reproduce the issue. u7oyK
    1. If the issue appears, your theme conflicts with the MTS plugin.
    2. If not, then the issue is with another plugin. You can continue enabling other plugins to pinpoint the plugin and contact their support for a resolution.

Once you complete the above steps, please let us know.

Looking forward to helping you. Thank you.

That is obviously because you are deactivating iThemes Security which is a mu plugin. Deactivating it causes the website to automatically raise security measures and disable admin access from anywhere other than one IP address. Leave that plugin active and you should not have any issues. 

Share this post


Link to post
Share on other sites

Hello,

Your site is live so we cannot deactivate plugin active on your site to check for the conflicting plugins. That's the reason we use HealthCheck plugin to troubleshoot the problem because it doesn't affect the website visitors. I would suggest you create a staging site where we could debug this issue for you or troubleshoot the issue using HealthCheck plugin by following the steps I shared before and let us know if you find any conflicting plugins.

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites
31 minutes ago, Pratik.d said:

Hello,

Your site is live so we cannot deactivate plugin active on your site to check for the conflicting plugins. That's the reason we use HealthCheck plugin to troubleshoot the problem because it doesn't affect the website visitors. I would suggest you create a staging site where we could debug this issue for you or troubleshoot the issue using HealthCheck plugin by following the steps I shared before and let us know if you find any conflicting plugins.

Looking forward to helping you. Thank you.

You don't need to deactivate other plugins. Deactivating Rank Math fixes it so what else are you diagnosing by deactivating other plugins?

Share this post


Link to post
Share on other sites

Hello,

As shown in the screencast, that theme is working perfectly with the Rank Math theme so it has to be a conflict with one of the plugins you are using on your website.

If you are comfortable, we can run the diagnose check on your site to confirm the conflicting plugin.

Once we narrow down the conflicting plugin, we will know what exactly is causing that issue.

In most of the cases, it is a code in some other plugin which does not follow WordPress's coding standards.

Please let us know how would you like us to proceed further.

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

It's fine now, don't worry - this has wasted so much time already so I just decided to redirect the URL to the homepage using Rank Math. 

Edited by alex.panagis

Share this post


Link to post
Share on other sites

Hello Alex,

I am sorry if it has been confusing.

1. This is not an issue with Rank Math + Expertly theme. As shown in our screencast, Rank Math works perfectly fine with Expertly theme.

2. It is possible that a combination of Rank Math + Expertly + some other plugin is causing this issue. Or, it could just be Rank Math + some other plugin.

3. We can't determine which plugin that is until we are able to deactivate some of the plugins and perform a health check using the plugin we showed you.

Do let us know if you want us to do the health check for you. 


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...