Check our WordPress 101 & 201 FREE Video Tutorials here
Jump to content
kirbysmarketing

[Rank Math SEO Plugin] 404 Error on Homepage

Recommended Posts

Hello,

I've been having a problem with my site and I think it started just after I switched over to Rank Math a month or two ago. At first, the homepage would give a 404 error at times. I eventually figured out that whenever there was a plugin or theme that needed to be updated is when the error would occur. As soon as I would update the plugin the homepage would work just fine...until the next plugin needed to be updated. 

Now, for the last couple weeks, the 404 error on the homepage has been occurring even when there are no plugins that need to be updated.

Also, lately, the initial time I go to the homepage it shows the 404 error. If I leave the tab open and come back and refresh the page it will load correctly sometimes. 

I've tried it on all different computers and devices, different browsers, different networks, etc. Sometimes it would happen in all instances and other times it would just happen on desktop computers and not on mobile devices. I'm pretty sure it has nothing to do with my cache or history needing to be cleared because of this. 

Again, I don't have the technical know-how to pinpoint what is causing the error, but to my best estimation, the problems began after I switched over to Rank Math. 

Please help me with this as I'm sure it's damaging our SEO and because customers have started to notice. 

Thank you and please let me know if there is anything I need to do. 

Dustin

Share this post


Link to post
Share on other sites

Hello,

I logged into your site and I edited the wp-config.php file on your server. I changed below line:

/** Enable W3 Total Cache */
define('WP_CACHE', true); // Added by W3 Total Cache

to

/** Enable W3 Total Cache */
define('WP_CACHE', false); // Added by W3 Total Cache

This variable is added by W3 Total cache, were you using that plugin before on your site? When this variable is set to true, WordPress checks for the advanced-cache.php file in wp-content folder which is missing on your site, which could be the reason for the 404 error on your homepage. I changed the Cache variable to false and your homepage now seems to be working fine.

Can you please check and confirm on your end?

Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello,

Thank you for contacting MyThemeShop and sorry for any inconvenience that might have been caused due to that.

I went ahead and flushed the rewrite cache by visiting this page on your website:

/wp-admin/options-permalink.php

and click on the Save Changes button, without making any changes to any setting.

That seemed to have fixed the issue. I'm not seeing a 404 page on your homepage anymore.

Can you please check and confirm on your end?

P.S. I can see the following code on your website's header on the frontend. You may want to check the custom CSS you added again:

#wpadminbar { display:none; }

 


🏁Rank #1 on Google With our WordPress SEO Plugin

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello,

Unfortunately, I don't think the problem is fixed. For me, the homepage loads just fine on my standard Chrome browser on my work computer. However, it doesn't load (404) when I open it in incognito mode. It doesn't load (404) on any of the other computers in the office in Chrome, Internet Explorer, or Firefox in regular mode. 

It loads just fine on my Android Chrome browser in normal mode and Incognito mode. 

Thank you!

Dustin

Share this post


Link to post
Share on other sites

Hello,

Do you see any errors or warnings in the debug.log file in wp-content/ folder on your server?

If possible, please add your FTP or cPanel details in the Sensitive Data Section so we can further debug this issue on your site?

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello,

I am getting Login incorrect error when I try to login with the provided FTP details. Please see the screenshot in the Sensitive Data Section

Can you please check the details again and share the correct username and password?

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

It seems to be working now. I'll let it be for a while and see if the problem returns. 

 

Thank you so much for your help. I really appreciate it. 

Dustin

Share this post


Link to post
Share on other sites

Hello,

It seems like this is still an issue. Now it seems like I'll go to the homepage and it will show the error. Then after a few minutes, I'll refresh it and it will work just fine. I have had this happen on multiple computers on different networks. It has seemed to work fine on mobile. 

Thank you!

Share this post


Link to post
Share on other sites

Hello,

I still can't log-in to your site with the provided FTP details? Can you please check that and add the correct FTP details in the Sensitive Data Section. I just want to check the debug log on your server to see if there are no errors reported from the Rank Math plugin.

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello,

I logged into your site and I edited the wp-config.php file on your server. I changed below line:

/** Enable W3 Total Cache */
define('WP_CACHE', true); // Added by W3 Total Cache

to

/** Enable W3 Total Cache */
define('WP_CACHE', false); // Added by W3 Total Cache

This variable is added by W3 Total cache, were you using that plugin before on your site? When this variable is set to true, WordPress checks for the advanced-cache.php file in wp-content folder which is missing on your site, which could be the reason for the 404 error on your homepage. I changed the Cache variable to false and your homepage now seems to be working fine.

Can you please check and confirm on your end?

Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

It seems like it's working now. I think I used to have that plugin installed but have since deactivated and uninstalled it. Is there a reason the code would still be active?

Thank you for your help!

Dustin

Share this post


Link to post
Share on other sites

Hello,

W3 is notorious in that case. It's known to create some minor issues when uninstalled.

Here's a detailed guide on how that should've been uninstalled
https://www.webnots.com/how-to-completely-delete-w3-total-cache-plugin/

Hope that helps. If you have any further question(s), please let us know. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Ok. I'll go through that post and see what I can do. I noticed the problem is occurring again recently on different computers on different networks. Hopefully, if I get rid of w3 completely it will solve it. 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×