[#CyberMonday] Get ALL our premium themes and plugins for just $99.47 (+FREE Goodies) [GET IT NOW]
Jump to content
anthony2

[Rank Math SEO Plugin] Sitemaps 404 and no index

Recommended Posts

The website I provided, I just got emails from Google Search Console this morning that says all of those sites:

  • Submitted URL blocked by robots.txt
  • Submitted URL seems to be a Soft 404
  • Submitted URL marked ‘noindex’

What is going on?

Share this post


Link to post
Share on other sites

Seems most of those errors are regarding to /cart , /my-account , /checkout pages that we use WooCommerce for. Should we be concerned? 

Share this post


Link to post
Share on other sites

Hello,

The error suggests you are submitting URLs on Google search console which are marked as noindex.

Can you share your login details in the "Sensitive Data" section so we can take a look at your settings?

You can add login details by clicking the Add button on the top and bottom right-hand side on this ticket and follow the instructions shown in the screenshot below:

rQoczm+

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello @anthony2

I cannot log in to your site with the link you provided in the Sensitive Data Section. It is redirecting me to a different site. Can you please check that and give us the correct link?

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello,

I logged into your site and I added below code in Dashboard >> Settings >> WP Rocket >> Advanced Rules >> Never Cache URLs:

/(.*)sitemap(.*).xml
/(.*)sitemap.xsl

WP Rocket was caching the sitemap URL which was causing the problem.

Also, I noticed the checkout, cart and my-account page on your site is not set to noindex. They are being indexed and shown in the Sitemap. 

Hope that helps. Please let us know if there is anything else.

Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Great, thank you! One thing I did not understand fully was your comment on checkout, cart, and my account page were set to no index-- where were you able to see that and why was it set that way? How do I change that as I need to update this on other websites too. 

Share this post


Link to post
Share on other sites

Hello,

Visit any page /cart, checkout or /my-account and check the robots meta tag in the page source. Those pages are still being indexed on your site. To set it to noindex, edit page and in Rank Math SEO Metabox in Advanced tab check the noindex checkbox. Please see the screenshots in the Sensitive Data Section.

Hope that helps. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...