Check our WordPress 101 & 201 FREE Video Tutorials here
Jump to content

Marcus_Tang

Member
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Marcus_Tang

  • Rank
    Member
  1. Hello, I installed RankMath to have my products in Woocommerce shown in the schema, mainly for Google Merchants. However, it still doesn't seem to work as it only shows "Website" and "Organisation": https://search.google.com/structured-data/testing-tool#url=www.maezu.com Is there a setting I need to change so that it captures my products in the schema too? Many thanks, Marcus
  2. Marcus_Tang

    Great and fast support, thank you!

    Had some great help from the guys on the RankMath plugin, thanks!
  3. Marcus_Tang

    [Rank Math SEO Plugin] Change canonical URL (again)

    I managed to change the site (URL) directly in the DB which corrected the canonical URL in the end. Thanks again for all your help!
  4. Marcus_Tang

    [Rank Math SEO Plugin] Change canonical URL (again)

    Thanks for getting back to me. It's a multisite, so I get the settings from Network Admin -> Sites -> Info Tab: Site (URL): https://domain.com Settings Tab: Siteurl: https://www.domain.com, Home: https://www.domain.com So it seems the culprit is the Site (URL) - or could it be because of the Yoast Plugin (which has now been deactivated by RankMath? Either way, I would be grateful for your advice on how to change the <link rel="canonical" href="https://domain.com"> to <link rel="canonical" href="https://www.domain.com"> Thank you very much.
  5. Marcus_Tang

    [Rank Math SEO Plugin] Change canonical URL (again)

    Hello, Thanks for your response, but unfortunately the htaccess tweak doesn't seem to affect the canonical URL. WHen I check the header, it still says <link rel="canonical" href="https://domain.com"> Is there an easy way to fix this?
  6. Hello, I know this topic has been discussed, but I couldn't find the answer in the other posts. RankMath shows my canonical url as https://domain.com but I have set it to https://www.domain.com everywhere else. I have found the following line on my site: <link rel="canonical" href="https://domain.com"> I am unsure where this line is being created and why it's set to the non WWW version. I am using the latest Wordpress. Is there a simple way to change this canonical URL reference from https://domain.com to https://www.domain.com As Google is now displaying search result as the non-WWW version, which I want to avoid. Many thanks!
×