[NEW!] Create a Vivid Website With The Magnus Theme for Just $19 - [GET IT NOW]
Jump to content
Nadine_Shemilt

[Rank Math SEO Plugin] HTTPS redirect error when plugin active

Recommended Posts

Hi!  When I activate the Rank Math plugin (i'm a mythemeshop subscriber), I then get, too many redirects, when I deactivate the plugin, the website works.  I don't know what setting might be causing this.  Thank you! 

Share this post


Link to post
Share on other sites

Hello,

For WP Review Pro problem, you need to disable "Enable User rating in old posts" option in wp-admin > Settings > WP Review Pro > Global > General. I disabled it for you. Please check again.

Thank you.

Share this post


Link to post
Share on other sites

Hello,

Thank you for contacting MyThemeShop and sorry for any inconvenience that might have been caused due to that.

Can you please add the FTP details as well in the sensitive area?

Also, can we disable the conflicting plugins when activating and configuring Rank Math on your website?

Looking forward to helping you.


👉Starting a new website? We recommend using SiteGround Hosting👈

🏁Rank #1 on Google With our WordPress SEO Plugin

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello, 

Yes but please try to ensure that there is as little downtime as possible and don't leave the website not working.  

When I enable rankmathseo the website will no longer load with the redirect error, and starts working again when I disable it. 

I have had no problems prior to this, I use cloudflare for my SSL.

Thanks!

Share this post


Link to post
Share on other sites

Hello,

Thank you for providing the details.

There was absolutely no downtime as I was suspecting some wrong Redirection rule from the beginning.

As soon as I installed the plugin, I deleted all the Redirections from the plugin.

Then I set the things up again in the Setup Wizard and confirmed if all the settings are correct.

Then I went over to the Import/Export tab and imported everything from your previous plugins and deactivated them, so no conflict arises.

Everything is working perfectly.

However, I'm not sure of a few settings on your website:
1. Why are you indexing the attachment pages?
2. Why is category sitemap not generated even though they are set to index?
3. Please check all the pages which are getting indexed (/sitemap_index.xml), I saw a few sample pages which should have either been deleted or not indexed.

Please check all the things on your end and let us know if we could be of further assistance to you.

We are here to help.

P.S. Can you please tell us which plan are you using on GoDaddy as it seems to be loading quite fast and we would love to recommend that plan to our users?


👉Starting a new website? We recommend using SiteGround Hosting👈

🏁Rank #1 on Google With our WordPress SEO Plugin

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Thank you so much for your extra comments on things to look at!  I had a look and addressed them, 

I'm having a problem removing the star rating from a page, in the page edit I change from star to no review, save page and then it reverts back to star rating and doesn't seem to want to change. 

I use a VPS with Digital Ocean and Server Pilot.  I've noticed WAY better speeds since switching to them, even though I know there is still some things I need to address on the wordpress side it's much faster. 

 

Share this post


Link to post
Share on other sites

Hello,

Glad that helped. I have updated the sensitive data further, you should check those post types as well. Least you want is to index unnecessary stuff on Google which adds little to value to your website.

For the Review thing, it seems like an issue in the WP Review Pro plugin.

An update is due for that and it should be released within the next 12 hours.

You can update directly from your WordPress dashboard once that is available and then try saving the review posts again.

Thank you for letting us know the server's configuration. Definitely, worth checking out, I felt the speed of our dedicated server (almost).

Please let us know if you need any further assistance, we are here to help.

Thank you.


👉Starting a new website? We recommend using SiteGround Hosting👈

🏁Rank #1 on Google With our WordPress SEO Plugin

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Thank you SO much for the extra information on the extra post types to no-index, that was great advice so I removed each of those. 

I updated the wp-review pro plugin this morning (along with wordpress), and still experiencing the same issue.  For example, trying to save the "about backyard games" page to "no review" type but it won't save and reverts to the star rating.  Other changes I make on that page are accepted. 

 

  • Like 1

Share this post


Link to post
Share on other sites

Hello,

For WP Review Pro problem, you need to disable "Enable User rating in old posts" option in wp-admin > Settings > WP Review Pro > Global > General. I disabled it for you. Please check again.

Thank you.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×