[NEW Release!] Get our newest WordPress theme, Reactor - Get it NOW for JUST $19
Jump to content
itsadvidking

[Rank Math SEO Plugin] Can't save the general setting section

Recommended Posts

I've a strange issue with rankmath. After updating the 1.0.1 version, i can't update the setting option.

wp-admin/admin.php?page=rank-math-options-general

On this section, whenever I press save the change, it returns 404. It happens only for this section. Any clue?

Note: I'm using wp rocket, tried to disable it and update it, but no luck. 

Edited by itsadvidking

Share this post


Link to post
Share on other sites

Hello,

I have logged in to your site to check the issue, and I found that there is definitely some kind of security feature on the server that is blocking the request. When I try to save the settings after removing the .htaccess field (using the browser's Developer Tools console) the settings are saved correctly. To be clear, I'm talking about this field: http://take.ms/ij9xF

This means that the field contains a word or something that is considered malicious, or at least suspicious by the security module/feature that is active on the server.

Even though that field does not change anything unless the checkbox above it is enabled, its contents are being sent through, and that is why the request gets blocked.

To fix this for now, I replaced your .htaccess file contents with the default that comes with a clean WP install:

# BEGIN WordPress

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Your previous .htaccess file's contents are now in a file called .htaccess_old, in the same folder.

The General Settings in Rank Math can now be saved correctly, however, other things on your site may not work perfectly. The proper solution would be to ask your hosting provider to disable the security feature that flags the content falsely, or at least whitelist this field somehow. Then, you can restore and use your previous .htaccess file.

Hope that helps.

Share this post


Link to post
Share on other sites

Hello,

Thank you for contacting MyThemeShop and sorry for any inconvenience that might have been caused due to that.

Please share your WordPress & FTP login details in the "Sensitive Data" section by editing your first post on this ticket and follow the instructions shown in the screenshot below:
sensitive.jpg

Please make a reply once you update the details, so we get notified.

Looking forward to helping you. Thank you.

 


👉Starting a new website? We recommend using SiteGround Hosting👈

🏁Rank #1 on Google With our WordPress SEO Plugin

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello,

Thank you for sending the details.

Can you please check the FTP details again as those are not working properly?

We need that to debug and check the error logs as we were able to reproduce it on your server.

Looking forward to helping you.


👉Starting a new website? We recommend using SiteGround Hosting👈

🏁Rank #1 on Google With our WordPress SEO Plugin

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello,
Thank you for the details, I tried troubleshooting a few things but still no luck, error log is empty, after few hours one of our developers will troubleshoot again.

Meanwhile could you please ask hosting if they have any security-related module enabled from their side? Also if they can provide any recent error log generated from the website.

Looking forward to helping you.
Thank you.


👉Starting a new website? We recommend using SiteGround Hosting👈

🏁Rank #1 on Google With our WordPress SEO Plugin

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello,

Sure, let us know.

Looking forward to help you.


👉Starting a new website? We recommend using SiteGround Hosting👈

🏁Rank #1 on Google With our WordPress SEO Plugin

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hey there

Any luck? 

My hosting company said there are no security issues or lock module enabled which may occur any trouble for the plugin. 

Note that, this plugin is working when it's in beta version. So i think if they have such module, then I couldn't save it from the very beginning. 

Share this post


Link to post
Share on other sites

Hello,

I see. Can you please request them to check the error log as well, if they are seeing anything?

Also, can you please try to revert your theme to a default theme and check if the issue persists?

Looking forward to helping you. Thank you.


👉Starting a new website? We recommend using SiteGround Hosting👈

🏁Rank #1 on Google With our WordPress SEO Plugin

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

This is what they told me - 

Nika Dyakova: Unfortunately, I need to inform you that we do not provide code-debugging or web-development. As a hosting provider, we specialize in certain areas only and may not know all the specifications of some software/applications.

 

Meanwhile, I tried to switch the theme and check again but not working till now. 

Share this post


Link to post
Share on other sites

Hello,

I have logged in to your site to check the issue, and I found that there is definitely some kind of security feature on the server that is blocking the request. When I try to save the settings after removing the .htaccess field (using the browser's Developer Tools console) the settings are saved correctly. To be clear, I'm talking about this field: http://take.ms/ij9xF

This means that the field contains a word or something that is considered malicious, or at least suspicious by the security module/feature that is active on the server.

Even though that field does not change anything unless the checkbox above it is enabled, its contents are being sent through, and that is why the request gets blocked.

To fix this for now, I replaced your .htaccess file contents with the default that comes with a clean WP install:

# BEGIN WordPress

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Your previous .htaccess file's contents are now in a file called .htaccess_old, in the same folder.

The General Settings in Rank Math can now be saved correctly, however, other things on your site may not work perfectly. The proper solution would be to ask your hosting provider to disable the security feature that flags the content falsely, or at least whitelist this field somehow. Then, you can restore and use your previous .htaccess file.

Hope that helps.

Share this post


Link to post
Share on other sites

Hello,

Sure. Though I doubt that could be the reason as they are just a caching plugin and would not be adding any security-related rules.

The best way would be to save the settings of WP Rocket again to confirm.

Hope that helps. If you have any further question(s), please let us know. Thank you.


👉Starting a new website? We recommend using SiteGround Hosting👈

🏁Rank #1 on Google With our WordPress SEO Plugin

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×