[OFFER ALERT!] This Halloween, Get Any Premium Theme for Just $19 [GET IT NOW]
Jump to content

[Rank Math SEO Plugin] rel=nofollow by internal links


Recommended Posts

All internal links are default with rel=nofollow atribute. What absolute is wrong. I must all internal backlinks check  and change that is to much work

I hope here is coming an update for.

And it is not that only internal links added after rank math has that  problem all links have the same problem

 

before.png 

Link to post
Share on other sites

`When I choice by settings external links follow then also the internal links are follow

I have choice that, it is not so much work to correct my external links then my internal links

But is of course a bug. The settings has to be seperated one setting for external links (default nofollow)  and one for internal links default follow

Link to post
Share on other sites
  • Support

Hello,

Thank you for contacting MyThemeShop today.

Please share your login details in the "Sensitive Data" section by editing your first post on this ticket and follow the instructions shown in the screenshot below:
sensitive.jpg

Please make a reply once you update the details, so we get notified.

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Link to post
Share on other sites

Hello,

I have updated the sensitive data as requested. Can you please check further?

 

When I choice by settings external links follow then also the internal links are follow

I have choice that, it is not so much work to correct my external links then my internal links

But is of course a bug. The settings has to be seperated one setting for external links (default nofollow)  and one for internal links default follow

Thank you.

 

 

 

Edited by erik140
Link to post
Share on other sites

I have deinstalled and delete rank math plugin and activated Yoast Premium and SEO Local Premium

And all my problems are gone. By internal links not a nofollow there is even not a possibility to set it in a easy way!

And focus keywords are not coming from a list but I just can type in. And the SEO analyse works.

And when I put 5 focus keywords for all I get a value. That was not by Rank Math.

 

If you still want that I test I will do the following things.

I will clone the site https://isa-loodgieters.nl site to for example https://oefenenwp.nl 

I will deactivate all plugins including wp-rocket cache.

And test the  plugin starting with new page.

The only thing is, can I close the site for google or is then Rank Math not working? 

Or only some modules are not working? There will be for example not be a connection with google search console.

And maybe there can be a problem with the keyword list. 

But if you think is worth to try I can try.

 

But on isa-loodgieters.nl the plugin is absolute not working in the right way. And after deinstalling Rank Math and activating again Premium Yoast all is working fine.

 

 

 

Link to post
Share on other sites
  • Support

Hi Erik (and Troy),

 

Can you please share a video cast of this issue? We are not sure where we should link for this issue. You can use a website/tool called useloom.com to take a screencast.

Once we are sure of the issue, we can begin to rectify it.

We look forward to helping you. 


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Link to post
Share on other sites

I have allready removed rank math.

But I Will try to discribe.

You need a existing website with internal links.

Then look for an internal link select the link and do CTRL+K

Make screenshot

Go to settings for tot set the external links to a different setting.

Close and open the site

Go again tot the same internal link.

Do CTRL+ K and take screenshot

Remove Rank Math install yoast free version repeat all. And compacte the screenshots. I am then very curious tot server the 4 screenshots.

 

Greetings

Erik

 

Edited by erik140
Autocorrect
Link to post
Share on other sites
Just now, erik140 said:

I have allready removed rank math.

But I Will try to discribe.

You need a existing website with internal links.

Then look for an internal link select the link and do CTRL+K

Make screenshot

Go to settings for tot set the external links to a different setting.

Close and open the site

Go again tot the same internal link.

Do CTRL+ K and take screenshot

Remove Rank Math installatie toast free version repeat all. And compacte the screenshots. I am then very curious tot server the 4 screenshots.

 

Greetings

Erik

 

Yoast

Link to post
Share on other sites
  • Support

Hi Erik,

We will take a closer look and release an update with the fix.

You can wait for the public release of this plugin if you would like to get the stable version.

If you need help with anything else, please do not hesitate to let us know.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Link to post
Share on other sites
  • Support

Hello,

Sorry to hear that.

Were you using an older version of the plugin? If so, can you please send in your WP login details through the sensitive data area and we will fix the issue for you (ofc if you decide to use the plugin).

It was a bug in one of the older versions but was fixed and is not present in the newer versions.

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Link to post
Share on other sites

I have deinstalled  yoast and installed again Rank Math version 0.9.9

The result are the same with one difference.

First it was like this when the settings by external links where no follow then the internal links showed by CTRL + K where also nofollow and  when the settings by external links where follow then the internal links showed by CTRL + K where also follow.

Now it makes no difference the internal links shower by select link CTRL+K is allways no follow

https://monosnap.com/file/7l1Pc0ZdVw2771Pr5E8xUZ8okm1zHN

 

 

 

 

Link to post
Share on other sites
  • Support

Hello,

Sorry that you are facing that issue.

Can you please share your login details in the "Sensitive Data" section by editing your first post on this ticket and follow the instructions shown in the screenshot below:
sensitive.jpg

Please make a reply once you update the details, so we get notified.

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...