[OFFER ALERT!] This Halloween, Get Any Premium Theme for Just $19 [GET IT NOW]
Jump to content

[Rank Math SEO Plugin] alt attributes problem in 'cover' and 'gallery' block.


Recommended Posts

when I make block 'cover' or 'gallery', there is a message 'Focus Keyword not found in image alt attribute(s)'. I write 'alt attributes' in media library but I don't know why...
 
amazing thing is, some post has no problem. and another post has a problem.
 
for example,
https://kingpinstudio.net/기타-표기/ this has a problem. it becomes problem after being 'cover' block.
Link to post
Share on other sites
  • Support

Hello,

Thank you for contacting MyThemeShop and sorry for any inconvenience that might have been caused due to that.

The alt text you added in the image is not the same as Focus keyword. Please see the screencast in the Sensitive Data Section.

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Link to post
Share on other sites

 

um... i don't understand it well. in that case, i write alt attribute as '한글 맞춤법 "기타 표기"' but i set my keyword as '"기타 표기"'. It means my alt attribute contains keyword and it has no problem at all. but it become problem after becoming 'cover'.

I think you mean block like 'cover' or 'gallery' doesn't harm SEO like Alt attribute, right? If i write alt attributes in library? um... i don't know well.

Link to post
Share on other sites
  • Support

Hello,

You are using the image as a background image in the post where alt test is not working. Background image doesn't have the alt text, it is used only in the image tag. Try adding the same image from the image module of the Gutenberg.

Hope that helps. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Link to post
Share on other sites
  • Support

Hello,

Yes, the Background image does not have the image tag and thus it doesn't have the alt attribute.

Hope that helps. Please let us know if you need any further assistance.

Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...