Check our WordPress 101 & 201 FREE Video Tutorials here
Jump to content
Ashish_Aryal

[Rank Math SEO Plugin] Link of one specific page is appearing as mainEntityOfPage for all other pages on my website

Recommended Posts

Hello,

I have one page: https://howtoweb.co.uk/server/4-free-cpanel-alternatives-for-linux-vps/

this link is being used as mainEntityOfPage for all other pages as below

"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/howtoweb.co.uk\/server\/4-free-cpanel-alternatives-for-linux-vps\/"}

Can someone tell me how can i fix this? i want the respective page's url to appear in the mainEntityOfPage

Im using RankMath plugin

Thanks in Advance

 

Ashish

 

Edited by Ashish_Aryal
additional informationa added

Share this post


Link to post
Share on other sites

Hello,

The problem is Helium theme uses Timber composer package which changes the WP get_posts() data and in Rank Math plugin we have used WP's get_posts object to generate the posts data. To fix it please add below filter code in your theme's functions.php file:

add_filter( 'rank_math/pre_simple_page_id', function( $id ) {
    if ( is_singular() ) {
        $obj = get_queried_object();
        $id = $obj->ID;
    }

    return $id;
});

Hope that helps. Thank you.

  • Like 1

🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello,

Thank you for contacting MyThemeShop and sorry for any inconvenience that might have been caused due to that.

I don't see any issue with the schema data on your site. The mainEntityOfPage takes the value of the current page, it's not showing /server/4-free-cpanel-alternatives-for-linux-vps/ on all the other pages of your site. Can you please give us a link of the page where schema markup is wrong as it looks ok to me on 4-free-cpanel-alternatives-for-linux-vps page.

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello,

 

Thank you for your reply

Im testing the page below

 

https://howtoweb.co.uk/server/install-webmin-on-ubuntu-16-with-vritualmin/

and im using google data testing tool and i have attached the result. Please let me know. I have cleared cache multiple times, both on wordpress and server level cache

check the result here https://imgur.com/a/Yz3mHrh

Thanks

Ashish

 

Share this post


Link to post
Share on other sites

Hello,

The mainEntityOfPage uses the canonical URL value of the page and after checking the page source of the above page I see the canonical url links to 4-free-cpanel-alternatives-for-linux-vps ( please see the screenshot in the Sensitive Data Section ). DId you change the canonical URL of the page?

Looking forward to helping you. Thank you.

 


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello,

Please share your login details in the "Sensitive Data" section by clicking the Add button on the top and bottom right-hand side on this ticket and follow the instructions shown in the screenshot below:
rQoczm+

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello,

To debug the issue I wanted to troubleshoot your site through HealthCheck plugin but even after deactivating Rank Math plugin, its metadata was showing up on the frontend.

It looks like server cache is enabled on your site which is making it really difficult to debug.

I would request you to please contact your hosting guys and ask them to disable and purge the cache, so we can further debug this issue.

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

The server level caching is completely disabled. Autooptimized is disabled as well. Can you try now

this is what i received from the hosting company support

Quote

So, Ashish, I tried multiple different things now. I do not understand where this error is coming from. The plugin seems to not load this correctly. The only other issue that it could be is the CDN, but I actually doubt it's causing this, and I cleared the CDN cache, too. You could try disabling the CDN in any case.
But you can ask the plugin developer for a thorough explanation of how this actually works, and where it might run into any caching issue.

 

Thanks for this help guys.

 

Ashish

Share this post


Link to post
Share on other sites

Hello,

I am still not able to debug this issue on your site. Even after deactivating Rank Math plugin, I see the meta tags generated by Rank Math on frontend ( please see the recording in the Sensitive Data Section ). I want to run a conflict check on your website using the Health Check plugin to see if other plugins or theme active on your site is not causing amy problem. Without disabling the cache it would be hard for us to check for any conflict as any changes we make would not reflect on the frontend.

If you want you can also perform a quick conflict check on your website using the instructions below. You can follow these instructions on your live website as well, as running this conflict check does not affect your website visitors.

Here are the steps for you to follow.

  1. Log into your WordPress Administrator, and navigate to the dashboard
  2. Navigate to 'Plugins', and go to 'add new'
    T9Ch6
  3. On the next page, enter 'Health Check' in the search bar and wait for the screen to refresh
    d0qdd
  4. The official Health Check plugin by WordPress.org should be visible as the first result. Please install and activate the plugin
    OP6bX
  5. You will reach the plugin page automatically, and a notice will appear. Click 'I understand' to continue
    kmNot
  6. On the WordPress Menu on the left, hover over the dashboard. You will notice a new 'Health Check' option, click on it
    j3RNi
  7. On the page that appears, there will be several tabs. Please navigate to the 'Troubleshooting' tab
    To02q
  8. Press the 'Enable Troubleshooting Mode' to start the troubleshooter
    zDFyO

Once you complete these steps, you are in troubleshooting mode. All the plugins on your website have been disabled only for you. Your theme has also been disabled, but only for you.

To diagnose the root-cause of your problem, you would enable each plugin one by one until an issue is found. The last plugin that causes the issue will probably the cause of the conflict. Here are the steps in more detail.

  1. With all plugins and the theme disabled, try reproducing the issue.
    1. If you still have the issue, your WordPress setup is the root of the problem.
    2. If not, then continue.
  2. On the top bar, navigate to the 'Troubleshooting Mode', hover over it, and enable the MyThemeShop plugin in question. After that, try to reproduce the issue. u7oyK
    1. If you have the issue, the plugin is conflicting with WordPress
    2. If not, then the plugin is not causing issues with WordPress. Continue to the next step
  3. Navigate to the "Troubleshooting Mode" in the top bar again, and enable any other plugin. Then try reproducing the issue. qHIDj
    1. If you have the issue, then the plugin you just activated is conflicting with the MyThemeShop Plugin
    2. If not, then this plugin is not causing issues with the MyThemeShop plugin

Repeat step no 3 by enabling one plugin at a time and checking if the problem exists. When the problem happens, the plugin you last activated is causing the issue.

 

If the issue is still not resolved, then it might be an issue with the theme you are using. Here is how you confirm if your theme and the MyThemeShop plugin are conflicting with each other.

  1. Enter troubleshooting mode again using the instructions above.
  2. Using the Troubleshooting mode, activate your regular theme by selecting the 'Use your current theme option'. kY14f
  3. Activate the MTS plugin you want to check and try to reproduce the issue. u7oyK
    1. If the issue appears, your theme conflicts with the MTS plugin.
    2. If not, then the issue is with another plugin. You can continue enabling other plugins to pinpoint the plugin and contact their support for a resolution.

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Disabling the rank math removes the rank math snippets from the html. I have tried this on chrome incognito mode

Here is the screenshot https://imgur.com/a/5eYeKsr

Is there anything else i should do?

Server cache is disabled

wordpress cache is disabled

cdn is disabled

Ashish

Edited by Ashish_Aryal
more info

Share this post


Link to post
Share on other sites

Hello,

Can you run a conflict check on your site by following the below instructions as I am still not able to run the conflict check? I see in incognito mode, the changes are reflected but after logging in, again the site shows the cached version. It looks like the mu-plugins Kinsta Must-use Plugins is storing this cache.

You can follow these instructions on your live website as well, as running this conflict check does not affect your website visitors.

Here are the steps for you to follow.

  1. Log into your WordPress Administrator, and navigate to the dashboard
  2. Navigate to 'Plugins', and go to 'add new'
    T9Ch6
  3. On the next page, enter 'Health Check' in the search bar and wait for the screen to refresh
    d0qdd
  4. The official Health Check plugin by WordPress.org should be visible as the first result. Please install and activate the plugin
    OP6bX
  5. You will reach the plugin page automatically, and a notice will appear. Click 'I understand' to continue
    kmNot
  6. On the WordPress Menu on the left, hover over the dashboard. You will notice a new 'Health Check' option, click on it
    j3RNi
  7. On the page that appears, there will be several tabs. Please navigate to the 'Troubleshooting' tab
    To02q
  8. Press the 'Enable Troubleshooting Mode' to start the troubleshooter
    zDFyO

Once you complete these steps, you are in troubleshooting mode. All the plugins on your website have been disabled only for you. Your theme has also been disabled, but only for you.

To diagnose the root-cause of your problem, you would enable each plugin one by one until an issue is found. The last plugin that causes the issue will probably the cause of the conflict. Here are the steps in more detail.

  1. With all plugins and the theme disabled, try reproducing the issue.
    1. If you still have the issue, your WordPress setup is the root of the problem.
    2. If not, then continue.
  2. On the top bar, navigate to the 'Troubleshooting Mode', hover over it, and enable the MyThemeShop plugin in question. After that, try to reproduce the issue. u7oyK
    1. If you have the issue, the plugin is conflicting with WordPress
    2. If not, then the plugin is not causing issues with WordPress. Continue to the next step
  3. Navigate to the "Troubleshooting Mode" in the top bar again, and enable any other plugin. Then try reproducing the issue. qHIDj
    1. If you have the issue, then the plugin you just activated is conflicting with the MyThemeShop Plugin
    2. If not, then this plugin is not causing issues with the MyThemeShop plugin

Repeat step no 3 by enabling one plugin at a time and checking if the problem exists. When the problem happens, the plugin you last activated is causing the issue.

 

If the issue is still not resolved, then it might be an issue with the theme you are using. Here is how you confirm if your theme and the MyThemeShop plugin are conflicting with each other.

  1. Enter troubleshooting mode again using the instructions above.
  2. Using the Troubleshooting mode, activate your regular theme by selecting the 'Use your current theme option'. kY14f
  3. Activate the MTS plugin you want to check and try to reproduce the issue. u7oyK
    1. If the issue appears, your theme conflicts with the MTS plugin.
    2. If not, then the issue is with another plugin. You can continue enabling other plugins to pinpoint the plugin and contact their support for a resolution.

Once you complete the above steps, please let us know.

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

I have done what you have asked.

Disabled all plugins but Rank Math and my current theme.

works when: Rank Math is enabled, Twenty nineteen is enabled

Doesnt work when theme is changed to Helium( my current theme)

I have left the setting as described above, please have a look and see if there is something you can do.

Ashish

Share this post


Link to post
Share on other sites

Hello,

It looks like some WP_Query is not reset properly in your theme which is causing this issue, please contact the theme author, they could help you better with this issue.

Also the admin-panel link you added in the Sensitive Data Section is no longer working. I am getting 404 error when I try to access backend through /backend, /wp-admin, /wp-login.php.

Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hay guys,

First of all, let me thank everyone from your team for doing everything you can to get my issue fixed. Unfortunately, I was unable to get this issue sorted. Tried everything i could but It didnt work for me. the exact copy of website on staging area is working as it should but the production area is not.

My only choice was to use a different plugin to manage SEO. I was very happy with how the plugin worked, i still have it installed in my other websites but unfortunately this didnt worked with my blog.

Again, Thank you. Everythingis working with the new plugin at the moment.

Perhaps there was some conflict with the theme, theme framework and Rank Math

Regards

Ashish

Share this post


Link to post
Share on other sites

Hello,

Our development team wanted to take a look at this issue but they were not able to login with the provided access details. Can you please check and the correct login details in the Sensitive Data Section?

Looking forward to helping you. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello,

Our Development team is checking this issue on their setup. I'll let you know as soon as I get a reply from them. In the meantime, if there is anything else, please let us know.

We appreciate your patience. Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello,

The problem is Helium theme uses Timber composer package which changes the WP get_posts() data and in Rank Math plugin we have used WP's get_posts object to generate the posts data. To fix it please add below filter code in your theme's functions.php file:

add_filter( 'rank_math/pre_simple_page_id', function( $id ) {
    if ( is_singular() ) {
        $obj = get_queried_object();
        $id = $obj->ID;
    }

    return $id;
});

Hope that helps. Thank you.

  • Like 1

🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites

Hello Pratik,

This snippet has fixed the issue. I want to thank you and your team for doing excellent job on this specific issue. You guys are amazing!

Ashish

  • Upvote 1

Share this post


Link to post
Share on other sites

Hello,

We are super happy that this resolved your issue. If you have any other questions in future, know that we are here to help you.

If you don't mind me asking, could you please leave us a review (if you haven't already) on https://wordpress.org/plugins/seo-by-rank-math/#reviews about your overall experience with Rank Math? We appreciate your time and patience.

If you do have another question in the future, please feel free to create a new forum topic, and it will be our pleasure to assist you again.

Thank you.


🏁Rank #1 on Google With our WordPress SEO Plugin.

Score a 💯on PageSpeed and Dominate Search Rankings.

✏ Editing theme files? Please create a child theme to make your changes update-proof.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×